Topic Options
Rate This Topic
#216883 - 11/28/11 03:15 AM Heater Not Working
fbodyNATION Offline
Registered: 06/28/10
Posts: 75
Loc: new orleans
On my way to work tonight my heater didnt come on i live approx.20 miles from my job & after about 13 miles the heater still didnt work i let all my cars run until they reach normal operating temps before i get in & pull off,everything seemed swell but as i got closer to work no heat at all temp gauge read normal the coolant in the radiator is full the coolant in the overflow bottle is full,so i dont see why the heater isnt working heres a list of things i replaced last week

1.)new radiator
2.)new thermostat
3.)new antifreeze/coolant
4.)new hoses
5.)new clamps
6.)new overflow/back up container
Heater Core isnt leaking
Temp stays at safe operating level,both cooling & a/c fans work,so guys what can it be? BTW my car is a 05 Comp G GTP if that helps any
#217174 - 01/25/12 11:35 PM Re: Heater Not Working [Re: fbodyNATION]
memogxp Offline
Junior Member
Registered: 01/24/12
Posts: 2
Your heater core is probably clogged, to check if it is clogged, theres 2 hoses that go to the heater core, theyre below the alternator, touch them to see if theyre warm, if both are warm your heater core is fine, but if one of them is cold, its clogged.
#218337 - 07/04/12 10:46 PM Re: Heater Not Working [Re: fbodyNATION]
Havocme Offline
Junior Member
Registered: 07/03/12
Posts: 5
Sorry to ressurect a dead thread, but this may pertain to a problem I have and instead of a new post, I could add here....

Once the engine is running for a while, do I need to crank the heat to get the hoses hot enough to check for a clog, they heat up normally with the engine?

And if it is clogged, what then?