Topic Options
Rate This Topic
#219067 - 04/09/13 10:14 PM Idle Problems FIXED!!!!
snowcrash Offline
Member
Registered: 05/05/03
Posts: 867
Loc: charlotte, nc
Figured I'd just post a new topic incase somebody might need some help.

After hearing from you guys and the guys at ZZP, I knew it had to be either the intake gaskets or the fuel injector O-rings.

Not really wanting to pull the intake, I sprayed carb cleaner once again directed on the injectors and determined they were the culprit.

I removed everything and when I went to pull them all out, they basically fell out since there was no tightness from the O-rings. I replaced all the O-rings(broke a little plastic off one of the injectors but it didn't seem to be an issue) and put them back in and sure enough, the car runs great again.

No more rough idle, especially sitting parked in gear at a light where it really ran like crap.

Anyways, if you have an idle issue, check your O-rings if you have checked everything else because it fixed our issue.

Thanks again for the help!

By the way, you can order from Rockauto for $2 and it comes as a 4 pack, so order two packs for $4 since you need 6 of them, plus $2 and some change for shipping and you are only out $6 basically. Advance Auto gets 4.59 for the same pack of Felpros.


Edited by snowcrash (04/09/13 10:16 PM)
_________________________
charlie
black 98 gtp sedan, 222,000 and running great with the new used tranny! laugh
zzp 3" d/p aluminized
dhp 1.0
Top
#219069 - 04/12/13 07:20 AM Re: Idle Problems FIXED!!!! [Re: snowcrash]
r.s.hutchinson Offline
Member
Registered: 01/01/08
Posts: 3900
Loc: Ontario, Canada
You didn't change the o-rings in the fuel rail while you were at it?

For the $4 dollars, why not? If the intake o-rings are bad, it's likely the rail ones are as well.
_________________________
00 Turbo GTP - 97 GTP - 03 GSXR600
Top
#219070 - 04/15/13 11:08 AM Re: Idle Problems FIXED!!!! [Re: snowcrash]
RooK Offline
Member
Registered: 03/07/05
Posts: 5158
Loc: Southern KY
Good to hear you got it fixed at least! When I tell people they have a vacuum leak on their car causing issues, they like to ignore me and blame every sensor despite it being a waste of money. Troubleshooting is apparently not in their cognitive capacity.
_________________________
'13 Mustang 3.7V6 - MT82
'00 GP SE (L67 Swap, XP, Headers, 3.25")
'98 GTP, '01 Bonne
Top
#219073 - 04/15/13 04:07 PM Re: Idle Problems FIXED!!!! [Re: snowcrash]
Blackarrow98GP Offline
Member
Registered: 06/29/06
Posts: 3618
Loc: CT, U.S.A
Originally Posted By: Blackarrow98GP
Before buying more parts, check it over for vacuum leaks.


Glad to hear it's fixed! Seems like it's always the little things you don't replace the first time around that come back to bite ya! wink
_________________________
Top
#219164 - 07/22/13 10:02 AM Re: Idle Problems FIXED!!!! [Re: r.s.hutchinson]
zuulmusic Offline
Member
Registered: 04/22/05
Posts: 3075
Loc: Cleveland, OH
Originally Posted By: r.s.hutchinson
You didn't change the o-rings in the fuel rail while you were at it?

For the $4 dollars, why not? If the intake o-rings are bad, it's likely the rail ones are as well.


Agree... should always replace all 12 O-rings if you have your injectors out. Also clean the mating surfaces of the intake and fuel rail so that they seal nicely.

The fuel rail side O-rings will last a bit longer, though, since they don't get as hot as the ones in contact with the hot engine.
Top
#219167 - 07/24/13 12:48 PM Re: Idle Problems FIXED!!!! [Re: snowcrash]
snowcrash Offline
Member
Registered: 05/05/03
Posts: 867
Loc: charlotte, nc
Sorry to be dumb, but where are the O-rings located at in fuel rail or as zuul said, the fuel side O-rings?

When I pulled the injectors out, there was only one o-ring on each injector at the bottom? That is why I said I only replaced 6 of them.

These are the only O-rings I have ever replaced though, doing the LIM and now.


Edited by snowcrash (07/24/13 12:50 PM)
_________________________
charlie
black 98 gtp sedan, 222,000 and running great with the new used tranny! laugh
zzp 3" d/p aluminized
dhp 1.0
Top
#219169 - 07/25/13 04:44 PM Re: Idle Problems FIXED!!!! [Re: snowcrash]
Richard Candelario Online
Member
Registered: 12/15/05
Posts: 5222
Loc: FT Carson, CO
If you didn't pull the injectors out of the fuel rail, you wouldn't have seen those upper o-rings.
_________________________

WizAire CAI w/9" K&N & HV3, 2.5" d/p w/h/f cat, Cobra CB, PowerSlot slots w/Hawk HPS, GR-2s, GMPP handling kit, NextLevel STBs, Pilot Sport A/S Plus tires.

98 L36/MM5
RaC
Top
#219171 - 11/07/13 10:16 PM Re: Idle Problems FIXED!!!! [Re: snowcrash]
snowcrash Offline
Member
Registered: 05/05/03
Posts: 867
Loc: charlotte, nc
I just pulled the whole rail with all the injectors attached out of the intake and moved it to the side.

I only saw 6 O-rings at the base of the injector nozzle so I put 6 back on there.

Anybody have a picture that shows where all 12 go or an injector that shows the placement of them.
_________________________
charlie
black 98 gtp sedan, 222,000 and running great with the new used tranny! laugh
zzp 3" d/p aluminized
dhp 1.0
Top
#219172 - 11/09/13 07:46 PM Re: Idle Problems FIXED!!!! [Re: snowcrash]
Blackarrow98GP Offline
Member
Registered: 06/29/06
Posts: 3618
Loc: CT, U.S.A
Here ya go:



#1 & #5 are injector o-rings, #4 is the O-ring backup (nylon collar).
_________________________
Top