Topic Options
Rate This Topic
#219185 - 05/31/14 08:44 PM Transmission slipping?
GTP2000 Offline
Member
Registered: 07/27/08
Posts: 98
Loc: Alberta/Canada
Hey everyone,

I've searched through old threads and read a bunch on this scenario, but I'd really appreciate your opinions. My ride (a 2000 GTP Coupe) with very minor mods (exhaust and cold air) ran great until today. At a stop sign I went to accelerate and noticed I was barely moving.

So I pulled into the parking lot and put the car in park. Went to shift into drive and noticed I didn't really feel anything happen. My bro is a mechanic said my tranny could be slipping. So I checked my fluid and I was low. I added the approved fluid and some "transmission fix" that should help the tranny grab. Warmed the car up to operating temp and tried again to no avail.

I'm thinking my bands might be screwed but its hard to say. My next step would be to change the fluid and filter to see if it makes a difference. I'd appreciate any thoughts or opinions. Hope this isnt the end of my GP. frown Thanks in advance!
_________________________

REDFIRE GTP COUPE
K&N CAI/magnaflow hiflo muffs u bend delete, res. delete 180 t-stat sunpro gauges /6000k HID projectors/HALO colour fogs, dragoneye corners-FATMAT soundproofing- complete Premier Audio-

***near future*** aeroforce scan gauge, powrtuner, autolites, 3.4 pulley!
Top
#219186 - 06/03/14 06:38 PM Re: Transmission slipping? [Re: GTP2000]
Richard Candelario Online
Member
Registered: 12/15/05
Posts: 5222
Loc: FT Carson, CO
WOW! A NEW THREAD! AND I GET TO ANSWER FIRST!!!

I'd check to see if the torque converter is working. Failing the clutch, then I'd open the tranny. How many miles do you have? How much do you drive the car hard?
_________________________

WizAire CAI w/9" K&N & HV3, 2.5" d/p w/h/f cat, Cobra CB, PowerSlot slots w/Hawk HPS, GR-2s, GMPP handling kit, NextLevel STBs, Pilot Sport A/S Plus tires.

98 L36/MM5
RaC
Top
#219187 - 06/04/14 12:54 AM Re: Transmission slipping? [Re: GTP2000]
GTP2000 Offline
Member
Registered: 07/27/08
Posts: 98
Loc: Alberta/Canada
Hey, thanks for the response. I have 128,000miles on it. I don't drive it super hard, but definitely open it up a few times a week.

I drove it a bit more to try and assess the problem. After slowly accelerating the car doesn't downshift into 3rd to reach 60mph when my RPMS are usually around 1800. Since it doesn't downshift it's staying around 3100 RPM.

I think it might be the torque converter...?
_________________________

REDFIRE GTP COUPE
K&N CAI/magnaflow hiflo muffs u bend delete, res. delete 180 t-stat sunpro gauges /6000k HID projectors/HALO colour fogs, dragoneye corners-FATMAT soundproofing- complete Premier Audio-

***near future*** aeroforce scan gauge, powrtuner, autolites, 3.4 pulley!
Top
#219188 - 06/04/14 09:59 AM Re: Transmission slipping? [Re: GTP2000]
Richard Candelario Online
Member
Registered: 12/15/05
Posts: 5222
Loc: FT Carson, CO
You're welcome.

I'm at a true loss with trannies, man. I think of them as a black magic that only necromancers can comprehend...or something like that. Since you're not getting a kick-down gear, perhaps the valvebody or solenoids aren't kicking in just right? Could be the PCM or BCM is having a bit of a seizure. I'm truly grasping straws right now. My 210k 00 GT has never had a tranny problem that I know of, and it sounds like I'm much harsher on mine than you are on yours.
_________________________

WizAire CAI w/9" K&N & HV3, 2.5" d/p w/h/f cat, Cobra CB, PowerSlot slots w/Hawk HPS, GR-2s, GMPP handling kit, NextLevel STBs, Pilot Sport A/S Plus tires.

98 L36/MM5
RaC
Top
#219189 - 06/05/14 07:19 PM Re: Transmission slipping? [Re: GTP2000]
Blackarrow98GP Offline
Member
Registered: 06/29/06
Posts: 3618
Loc: CT, U.S.A
I'm no trans expert either, but here's a site that lists common problems with the 4T65E: http://tripleedgeperformance.com/4T65E-Common-Problems.html

Hopefully that will help you track down your gremlin!
_________________________
Top
#219190 - 06/05/14 11:42 PM Re: Transmission slipping? [Re: Blackarrow98GP]
GTP2000 Offline
Member
Registered: 07/27/08
Posts: 98
Loc: Alberta/Canada
Thanks Blackarrow98GP! That was a helpful read. From the sounds of it I've got a slipping or broken forward apply band. Gonna be a pricey fix..
_________________________

REDFIRE GTP COUPE
K&N CAI/magnaflow hiflo muffs u bend delete, res. delete 180 t-stat sunpro gauges /6000k HID projectors/HALO colour fogs, dragoneye corners-FATMAT soundproofing- complete Premier Audio-

***near future*** aeroforce scan gauge, powrtuner, autolites, 3.4 pulley!
Top
#219191 - 06/06/14 09:47 AM Re: Transmission slipping? [Re: GTP2000]
Richard Candelario Online
Member
Registered: 12/15/05
Posts: 5222
Loc: FT Carson, CO
BLACKARROW! Here I was thinking you were long gone from this site. Welcome back.

lol, thought just occured to me...have yall seen that newest Muppets movie? Where Jason Segel, Amy Adams, and Walter walk into the Muppets' compound and it's an embarrassing shade of its former glory? yeah, that's almost what this site feels like right now.
_________________________

WizAire CAI w/9" K&N & HV3, 2.5" d/p w/h/f cat, Cobra CB, PowerSlot slots w/Hawk HPS, GR-2s, GMPP handling kit, NextLevel STBs, Pilot Sport A/S Plus tires.

98 L36/MM5
RaC
Top
#219192 - 06/06/14 12:04 PM Re: Transmission slipping? [Re: GTP2000]
Blackarrow98GP Offline
Member
Registered: 06/29/06
Posts: 3618
Loc: CT, U.S.A
You're welcome, glad to be of help. Hope everything works out for ya!

Heya Rick,
Thanks man, good to see you back as well. I still check in once in awhile, and I miss the good old days too. cool
_________________________
Top
#219193 - 06/08/14 12:32 PM Re: Transmission slipping? [Re: GTP2000]
Richard Candelario Online
Member
Registered: 12/15/05
Posts: 5222
Loc: FT Carson, CO
cheers
_________________________

WizAire CAI w/9" K&N & HV3, 2.5" d/p w/h/f cat, Cobra CB, PowerSlot slots w/Hawk HPS, GR-2s, GMPP handling kit, NextLevel STBs, Pilot Sport A/S Plus tires.

98 L36/MM5
RaC
Top
#219194 - 06/08/14 12:32 PM Re: Transmission slipping? [Re: GTP2000]
Richard Candelario Online
Member
Registered: 12/15/05
Posts: 5222
Loc: FT Carson, CO
LMAO! here I was expecting the old smiley of clinking steins...nope. All it gave was the text above. *sigh*
_________________________

WizAire CAI w/9" K&N & HV3, 2.5" d/p w/h/f cat, Cobra CB, PowerSlot slots w/Hawk HPS, GR-2s, GMPP handling kit, NextLevel STBs, Pilot Sport A/S Plus tires.

98 L36/MM5
RaC
Top
#219203 - 09/01/14 09:34 PM Re: Transmission slipping? [Re: GTP2000]
snowcrash Offline
Member
Registered: 05/05/03
Posts: 867
Loc: charlotte, nc
You might ought to check in buying a used transmission from Ed Morad and having it installed or installing it yourself. We got one for our 98GTP and it was like 650.00 shipped I think. The car isn't worth what a rebuilt was going to cost and a shop price was high also.

The transmission only had 92 or 98,000 when we got it used from Morad. The shifting seemed to still not shift quite right after installing but I think it has more to do with the car and motor having so many miles on it. Car is still going strong though. It does fine but it just seems like when pulling up a hill say, the car builds boost rather than shifting down. A quick mass of the throttle will get it to kick down and go. That is why I say it is more to do with the car since the old transmission did this also before going out.
_________________________
charlie
black 98 gtp sedan, 222,000 and running great with the new used tranny! laugh
zzp 3" d/p aluminized
dhp 1.0
Top