Topic Options
Rate This Topic
#222788 - 01/21/21 02:28 PM Hard starting when warm after engine rebuild
Jrp79 Offline
Junior Member
Registered: 11/16/20
Posts: 3
Loc: GEORGIA
Just rebuilt the engine in my 02 gp gt. Have 300 miles on it plus about 5 hours idle time. First start of the day or when motors cold it starts fine. After i shut it off then try to restart itll crank for a few seconds start then immediately stall. I have to give it gas for a few seconds to keep it running but when its running it runs fine.. No pending engine codes. New plugs, wires. Fuel pressure is 55psi koeo, about 52psi running then jumps up to about 61 when vac line unplugged. Psi is about 58 when cranking.
Any one have any ideas
Top
#222790 - 01/21/21 10:36 PM Re: Hard starting when warm after engine rebuild [Re: Jrp79]
Richard Candelario Offline
Member
Registered: 12/15/05
Posts: 5258
perhaps air metering and control? IAC, IAT, MAF, MAP, TPS, or O2 (long shot, addmitedly). If you're on Discord, ZZP has a pretty robust server going. Let me know if you want those instructions. Your issue doesn't ring a bell as to something we've faced here. My first thoughts went to a fueling problem, as well. Since you've ruled that out, I would go to breathing or spark. I'm going to assume you've already replaced the plugs and wires with your rebuild. Testing the MAF is pretty easy: with it running, you should be able to unplug it and it runs fine. When you unplug the MAF, it should start to stumble and roughen the idle.
_________________________

WizAire CAI w/9" K&N & HV3, 2.5" d/p w/h/f cat, Cobra CB, PowerSlot slots w/Hawk HPS, GR-2s, GMPP handling kit, NextLevel STBs, Pilot Sport A/S Plus tires.

98 L36/MM5
RaC
Top
#222796 - 02/21/21 11:12 PM Re: Hard starting when warm after engine rebuild [Re: Jrp79]
Tom Joyce Offline
Junior Member
Registered: 02/21/21
Posts: 1
Loc: Bucks County, Pennsylvania
Is there no moderator to delete these spam messages? (Obviously, NOT this post) ...

I'm a new owner of a 1999 Grand Prix, looking for some forums. Found a couple, plus this one. This one seems inundated with spam.
_________________________
Tom Joyce
2019 Kia Niro LX w/ Adv. Tech Pkg.
1999 Grand Prix Coupe GTP
Top
#222798 - 03/10/21 06:20 PM Re: Hard starting when warm after engine rebuild [Re: Jrp79]
Richard Candelario Offline
Member
Registered: 12/15/05
Posts: 5258
Yeah, sorry. The mods and admins all ditched the place a few years back. I'm really the only one left to keep an eye on things.

This forum is chock-full of lessons learned and suggestions. I can almost guarantee that what ever you wish to know about your new car, this place has it. Welcome to the might-as-well-be-dead site. I'm glad to see a new face around here.
_________________________

WizAire CAI w/9" K&N & HV3, 2.5" d/p w/h/f cat, Cobra CB, PowerSlot slots w/Hawk HPS, GR-2s, GMPP handling kit, NextLevel STBs, Pilot Sport A/S Plus tires.

98 L36/MM5
RaC
Top